22

 How to configure a simple static routing in packet tracer using a simple topology with two routers

here we go


Steps:

Step 1:First Create a topology like this







you will get a red light first this is configured topology

Step 2: Configure ip address to routers go to global configuration mode in R1 and R2 configure connected interfaces

In Router 1

Interface Fastethernet0/0 in global configuration mode


R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit


Interface Serial 2/0

R1(config)#interface serial 2/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#no shutdown
R1(config-if)#exit


In Router 2

Interface Fastethernet 0/0

R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit


Interface Serial 2/0

R2(config)#interface serial 2/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit


Step 3 : Assign ip address for both Pc's with appropriate ip and subnetmask and default gateway How to Configure IP address ,Default gateway to PC ?

Check Routing table by giving this command,It has only directly connected network.
R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    10.0.0.0/8 is directly connected, FastEthernet0/0
C    20.0.0.0/8 is directly connected, Serial2/0

Step 4: Now configure both router with static route



By default, Routers Know only directed connected networks here Router 1 know only 10.0.0.0 and 20.0.0.0 it doesn't know the 30.0.0.0 like this R2 doesn't know about 10.0.0.0.So We are going to add Static route to this both router

  R1(config)#ip route Destination Network| Destination N/W SubnetMask |Next Hop Address

In Router R1,Just give this command,In this case Destination is 30.0.0.0 and its subnet mask is 255.0.0.0 next hop address is 20.0.0.2


R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2


In Router R2


R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

Thats it!!..Now both routers know all networks,check by ping ip address of host



  • Check Routing table by giving this command,


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    10.0.0.0/8 is directly connected, FastEthernet0/0
C    20.0.0.0/8 is directly connected, Serial2/0
S    30.0.0.0/8 [1/0] via 20.0.0.2


Step 5:Double click PC move to desktop then command prompt give the command ping 30.0.0.10 in PC 0 you will get reply from 30.0.0.10 like this




From PC1




Configure a Simple Static Routing in Packet Tracer Full Video

Post a Comment

  1. i am getting everything except pinging. any idea wer i wrong?

    ReplyDelete
  2. after ping its showing request time out.....

    ReplyDelete
  3. Thanx Bra!!!!!!!!!! You Really Helped Me Out!!!

    ReplyDelete
  4. Please i want to know the CLI that changes the protocol from down to up??

    ReplyDelete
  5. unable to connect 3 routers. R1--- R2 ---R3. r1 CANNOT SEND PACKETS TO r3?????

    ReplyDelete
    Replies
    1. what response you have got.check your routing table of all routers by giving command in privileged mode 'show ip route' if any network not prensent in that router then add a static route with next hop address or just try this..

      http://chennaicisco.blogspot.in/2013/01/how-to-configure-static-route-using.html

      this is the example with three routers..

      Delete
  6. how to configure static route and EIGRP routing on the same network give me the answer

    ReplyDelete
  7. i did this all but no ping going from one computer two other and ping go from one router to other router but in pc1 to pc2 no ping go..........this type of 3 types i done but ping is not going from me plz solve my problem all connection is perfect and blinking all

    ReplyDelete
    Replies
    1. go through all your data you will see were your mistake is

      Delete
  8. this post is so helpful, sie sie

    ReplyDelete
  9. how to connect 4 pc in static routing?

    ReplyDelete
  10. thank for you website that show command for me

    ReplyDelete
  11. ip route command dnt work in packet tracer. is that true?
    if yes, thn plz tell me which command i should use in pkt tracer?

    ReplyDelete
    Replies
    1. it works on packet tracer..sorry for the delayed reply..

      Delete
  12. How to connect pc to pc using CLI?
    cOZ I can't connect .it

    ReplyDelete
    Replies
    1. no need of CLI just connect two pc with cross cable and assign an ip address for the two pc in same network..then you could ping them...

      Delete
  13. Every module of Cisco networking gives me a confidence to start advancing my networking skills. I have learned the simple tricks of configuring the static routing for a packet. This is one of most interesting experiences in the networking lifetime. Nursing school entry Essay writing aid

    ReplyDelete

 
Top