4
Interior Gateway Routing Protocol is distance vector routing protocol.It is a cisco proprietery Routing Protocol

It knows only neighbors,
It doesn't know entire topology,Routing by rumors
It doesn't support classless network
It will update routing informations every 90 seconds(Periodic Updates)
It sends entire routing table to its neighbour

IGRP-Interior Gateway Routing Protocol
Administrative Distance-100
Maximum Hop count-255
Metric - (Bandwidth +Delay)
Atonomous System(AS),it is using to bring the routers under common adminstration domain.
Routers in different AS won't exchange routing updates



Now ,we see how to configure igrp in a routers,

Step 1:Create topology like this


Configure Igrp in Routers to Enable Routing



Step 2:Do basic configurations to all router interfaces and host




In Router R1,



R1(config)#interface fastethernet 2/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit


R1(config)#interface serial 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit





In Router R2,


R2(config)#interface serial 1/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#no shutdown
R2(config-if)#exit



R2(config)#interface serial 1/1
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#encapsulation ppp
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit





In Router R3,


R3(config)#
R3(config)#interface serial 1/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
R3(config-if)#encapsulation ppp
R3(config-if)#no shutdown
R3(config-if)#exit




R3(config)#
R3(config)#interface fastethernet 2/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit






Step 3:Configure IGRP Routing Protocol in all routers,



R1(config)#router igrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit

Here,100 is atonomous system number



In Router R2,


R2(config)#router igrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit




In Router R3,


R3(config)#router igrp 100
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit







Post a Comment

 
Top