15
How to configure DHCP in cisco router using packet tracer simulator,


Step 1:Create a topology like this,






Step 2:Configure router interface fastethernet0/0 and fastethernet

1/0 with ip address.

R1#config t
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown


R1(config-if)#exit
R1(config)#interface fastethernet 1/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Step 3:Configure DHCP pool for the network 10 and 20,

In Router R1,Global Configuration mode,


R1(config)#service dhcp

This command is to enable the dhcp server on a router. Routers in packet tracer won't accept this command.By default dhcp will be running on router so skip 'service dhcp' command if you are configuring dhcp in packet tracer,just create a network pool for the network it will work.Use this in real time or other simulators like gns3.


R1(config)#ip dhcp pool 10network         "where '10network' is the pool name we can use what ever we
want.This command get us into the DHCP Configuration mode."

R1(dhcp-config)#network 10.0.0.0 255.0.0.0        "It defines the network range to be leased"

R1(dhcp-config)#dns-server 10.0.0.2       "Ip address for the dns server."

R1(dhcp-config)#default-router 10.0.0.1       "Default gateway for this network."

R1(dhcp-config)#exit


DHCP pool for 10 Network

R1(config)#ip dhcp pool 10network
R1(dhcp-config)#network 10.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 10.0.0.1
R1(dhcp-config)#exit

DHCP pool for 20 Network

R1(config)#ip dhcp pool 20network
R1(dhcp-config)#network 20.0.0.0 255.0.0.0
R1(dhcp-config)#dns-server 10.0.0.2
R1(dhcp-config)#default-router 20.0.0.1
R1(dhcp-config)#exit



Now, Click on any of the PC->Desktop->ip configuration->Choose DHCP.Now PC will get an ip from DHCP server.











Few more command We can use, but we can't configure this in packet tracer.Use gns3 simulator for this.


R1(dhcp-config)#netbios-server x.x.x.x 'where x.x.x.x is ip address of netbios server.

R1(dhcp-config)#lease x   'where X is the number it sets the lease time,by default 1 (i.e. one day).

R1(dhcp-config)#ip dhcp excluded address x.x.x.x x.x.x.x   'Range of ip address excluded from the pool it will not be leased to the clients'.

R1(dhcp-config)#ip dhcp excluded address x.x.x.x    'To exclude only one ip address from the range of ip address'.


Ex.

R1(dhcp-config)#netbios-server 10.0.0.2
R1(dhcp-config)#lease 2
R1(dhcp-config)#ip dhcp excluded address 10.0.0.1 10.0.0.10
R1(dhcp-config)#ip dhcp excluded address 10.0.0.35







Trouble shooting commands,






Router#show ip dhcp binding    'Displays a list of all bindings created.'


Router#show ip dhcp binding w.x.y.z     'Displays the bindings for a specific DHCP client with an IP address of w.x.y.z.'


Router#clear ip dhcp binding a.b.c.d      'Clears an automatic address binding from the DHCP server database.'


Router#clear ip dhcp binding *      'Clears all automatic DHCP bindings.'


Router#show ip dhcp conflict      'Displays a list of all address conflicts recorded by the DHCP server.'


Router#clear ip dhcp conflict a.b.c.d     'Clears address conflict from the database.'


Router#clear ip dhcp conflict *      'Clears conflicts for all addresses.'


Router#show ip dhcp database      'Displays recent activity on the DHCP database.'


Router#show ip dhcp server statistics      'Displays a list of the number of messages sent and received by the DHCP server.'


Router#clear ip dhcp server statistics






Post a Comment

  1. Replies
    1. This video will help you in process to Netgear Router Reset, install and setup & Configuration, Netgear Router Error 651 in windows 10, Windows 7, Windows 8.1 etc. Netgear Router Technical Support Phone Number +1-8002046959 is available 24/7 for their customers.

      Watch YouTube Video: https://www.youtube.com/watch?v=0-35HpKLMB0

      Delete
  2. This blog is very interesting for Linksys Router Support.if you find more information
    Linksys Router Technical Support

    ReplyDelete
  3. I read this post.This blog is very interesting and use-full for Cisco Router Support and its issues....
    thanks for sharing this post.....
    if you find more information Cisco Router Support visit our site.

    ReplyDelete
  4. This comment has been removed by a blog administrator.

    ReplyDelete
  5. There are many useful tutorials on ur blog. Thanks so much!

    ReplyDelete
  6. Good posting, it is fully help me . thanks for share..Linksys Router Technical Support also call Toll Free No 1-800-231-4635 For US/CA.

    ReplyDelete
  7. Thank you i did really need this topic you share a very nice information about the IP Tracer it's great work.
    IP locator

    ReplyDelete
  8. Somebody necessarily help to make severely posts I might state. This is the first time I frequented your website page and to this point? I surprised with the research you made to create this particular post extraordinary. Well done admin..

    CCNA Training in Chennai

    ReplyDelete
  9. This is BT technical support for all BT products if you have any kind of
    info About the BT products now dial our toll free customer care no 0800-680-0619

    bt email support:-
    http://pcehelp.com/bt-support/bt-email-support-number-uk-0800-680-0619/
    yahoo technical support:-
    http://pcehelp.com/yahoo-email/technical-support-number-0800-680-0619/
    bt technical support:-
    http://pcehelp.com/bt-support/bt-technical-support-number-0800-680-0619/
    skype support number:-
    http://pcehelp.com/skype/skype-technical-support-0800-680-0619/
    hp technical support
    http://pcehelp.com/hp/hp-technical-support-0800-680-0619/
    adobe technical support
    http://pcehelp.com/adobe-support/adobe-technical-support-0800-680-0619/


    ReplyDelete
  10. bt email support, bt mail support, bt yahoo customer support, bt yahoo support number, bt customer service,
    yahoo email support, bt phone number, contact bt, bt customer care, bt help
    bt email support

    ReplyDelete
  11. I enjoyed reading your article :) PLease continue publishing helpful topics like this. Regards, from Let's get gadget, a company whose into selling
    cordless phone answering machine

    ReplyDelete
  12. Thanks For Best information !@ if you are facing any issues regarding cisco router Call Toll-free : 1-8002046959 for 24*7 Days and

    Visit: Cisco Router Technical Support

    Watch YouTube Video: Cisco Router Support Number

    ReplyDelete
  13. Hi, good job you are doing here.
    can you do an example of an instance where you have two routers connected to each other. if router A is the dhcp server, how can the computers connected to router B receive ip addresses through router A's dhcp

    ReplyDelete
  14. Really it was an awesome article...very interesting to read..You have provided an nice article....Thanks for sharing..
    Android Training in Chennai
    Ios Training in Chennai

    ReplyDelete

 
Top