0
In this post we are going to see how to configure Frame Relay with Routing Protocols using cisco router as frame relay switch in GNS3.


For that go to this link  CLICK HERE!!
Do all configurations except static routing(i.e. is step 6).Instead of Static routing we are going to configure dynamic with any routing protocols from this RIP,IGRP,OSPF and EIGRP.I am going to use RIP-Routing Information Protocols.

Before that do this small modification in Ho Router,stop the split horizon service in serial sub interfaces so that routing updates can be sent through same interface from where it was received.Split Horizon won't allow to sent back the routing updates on the same interface that was received .

Frame Relay with Routing Protocols Using Cisco Routers in GNS3






In Router HO,

HO(config)#interface serial1/0.23
HO(config-subif)#no ip split-horizon
HO(config-subif)#exit


HO(config)#interface serial1/0.4
HO(config-subif)#no ip split-horizon
HO(config-subif)#exit



Now, Enable dynamic routing using RiP,


In Router HO,

HO(config)#router rip
HO(config-router)#network 10.0.0.0
HO(config-router)#network 20.0.0.0
HO(config-router)#network 90.0.0.0
HO(config-router)#exit


In Router BO1,

BO1(config)#router rip
BO1(config-router)#network 20.0.0.0
BO1(config-router)#network 30.0.0.0
BO1(config-router)#exit


In Router BO2,

BO2(config)#router rip
BO2(config-router)#network 20.0.0.0
BO2(config-router)#network 40.0.0.0
BO2(config-router)#exit


In Router BO3,

BO3(config)#router rip
BO3(config-router)#network 50.0.0.0
BO3(config-router)#network 90.0.0.0
BO3(config-router)#exit



Now check routing table of all routers using this command,


HO#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R    50.0.0.0/8 [120/1] via 90.0.0.2, 00:00:03, Serial1/0.44
C    20.0.0.0/8 is directly connected, Serial1/0.23
R    40.0.0.0/8 [120/1] via 20.0.0.3, 00:00:19, Serial1/0.23
C    10.0.0.0/8 is directly connected, FastEthernet2/0
C    90.0.0.0/8 is directly connected, Serial1/0.44
R    30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:15, Serial1/0.23




Ping all host from 10.0.0.10,check whether you get reply from all host.


ping 30.0.0.10
ping 40.0.0.10
ping 50.0.0.10



Frame Relay with Routing Protocols Using Cisco Routers in GNS3




Troubleshooting commands,



HO#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.23

  input pkts 1             output pkts 1            in bytes 34
  out bytes 34             dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1         out bcast bytes 34
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:54, last time pvc status changed 00:02:35

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.23

  input pkts 1             output pkts 1            in bytes 34
  out bytes 34             dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 1         out bcast bytes 34
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:57, last time pvc status changed 00:02:38

DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.44

  input pkts 1             output pkts 5            in bytes 34
  out bytes 1743           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 5         out bcast bytes 1743
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:59, last time pvc status changed 00:02:40


HO#show frame-relay map
HO#show frame-relay lmi
HO#debug frame-relay lmi
HO#debug frame-relay packet
HO#debug frame-relay


In FRSW,


FRSW#show frame-relay route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial1/0       102             Serial1/1       201             active
Serial1/0       103             Serial1/2       301             active
Serial1/0       104             Serial1/3       401             active
Serial1/1       201             Serial1/0       102             active
Serial1/2       301             Serial1/0       103             active
Serial1/3       401             Serial1/0       104             active



Post a Comment

 
Top