In this post we are going to see how to configure simple point to point frame relay connection between Head Office and Branch Office using cisco router instead of frame relay switch in GNS3.
Step 1:Create topology like this,
Step 2:Configure Head Office router and Branch Office router with ip address and make sure serial interface encapsulation that connected to FRSW is frame relay on both Head office and Branch office router.
In Router HO,Global Config mode
HO(config)#interface fastethernet2/0
HO(config-if)#ip address 10.0.0.1 255.0.0.0
HO(config-if)#no shutdown
HO(config-if)#exit
HO(config)#interface serial 1/0
HO(config-if)#ip address 20.0.0.1 255.0.0.0
HO(config-if)#encapsulation frame-relay
HO(config-if)#no shutdown
HO(config-if)#exit
In Router BO,Global Config mode
BO(config)#interface fastethernet 2/0
BO(config-if)#ip address 30.0.0.1 255.0.0.0
BO(config-if)#no shutdown
BO(config-if)#exit
BO(config)#interface serial 1/0
BO(config-if)#ip address 20.0.0.2 255.0.0.0
BO(config-if)#encapsulation frame-relay
BO(config-if)#no shutdown
BO(config-if)#exit
Step 3:Configure the Qemu host with ip address and default gateway like i have given in a topology.I am using qemu host with microcore image, to configure this host follow this instruction
Right click on Qemu host and start the host and wait for few minutes to boot, then configure ip address and default gateway with this command below.
In Qemu1,
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 10.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 10.0.0.1
root@box:~#route add default gw 10.0.0.1
In Qemu2
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 30.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 30.0.0.1
root@box:~#route add default gw 30.0.0.1
Step 4:Frame Relay Switch Configuration
Command to enable Frame Relay in Cisco Router is
FRSW(config)#frame-relay switching
Now configure the interface serial1/0 and interface serial 1/1 with this command,
FRSW(config)#interface serial 1/0
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 102 interface serial 1/1 201
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
FRSW(config)#interface serial 1/1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 201 interface serial 1/0 102
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
Step 5:Configure the Router HO with static route for the network 30.0.0.0 and B0 for the network 10.0.0.0
In Head Office Router,
HO(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
In Branch Office Router,
BO(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
Step 6:Now go to the qemu host in 10.0.0.0 network and ping the host in 30.0.0.0 network
ping 30.0.0.10
Troubleshooting commands,
HO#show frame-relay pvc
PVC Statistics for interface Serial1/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
input pkts 38 output pkts 50 in bytes 3610
out bytes 4746 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 1 out bcast bytes 34
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:20:39, last time pvc status changed 00:19:39
HO#show frame-relay map
Serial1/0 (up): ip 20.0.0.2 dlci 102(0x66,0x1860), dynamic,
broadcast,, status defined, active
HO#show frame-relay lmi
LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 149 Num Status msgs Rcvd 133
Num Update Status Rcvd 0 Num Status Timeouts 16
To check packets belongs to frame relay
HO#debug frame-relay lmi
HO#debug frame-relay
HO#debug frame-relay packet
Step 1:Create topology like this,
Step 2:Configure Head Office router and Branch Office router with ip address and make sure serial interface encapsulation that connected to FRSW is frame relay on both Head office and Branch office router.
In Router HO,Global Config mode
HO(config)#interface fastethernet2/0
HO(config-if)#ip address 10.0.0.1 255.0.0.0
HO(config-if)#no shutdown
HO(config-if)#exit
HO(config)#interface serial 1/0
HO(config-if)#ip address 20.0.0.1 255.0.0.0
HO(config-if)#encapsulation frame-relay
HO(config-if)#no shutdown
HO(config-if)#exit
In Router BO,Global Config mode
BO(config)#interface fastethernet 2/0
BO(config-if)#ip address 30.0.0.1 255.0.0.0
BO(config-if)#no shutdown
BO(config-if)#exit
BO(config)#interface serial 1/0
BO(config-if)#ip address 20.0.0.2 255.0.0.0
BO(config-if)#encapsulation frame-relay
BO(config-if)#no shutdown
BO(config-if)#exit
Step 3:Configure the Qemu host with ip address and default gateway like i have given in a topology.I am using qemu host with microcore image, to configure this host follow this instruction
Right click on Qemu host and start the host and wait for few minutes to boot, then configure ip address and default gateway with this command below.
In Qemu1,
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 10.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 10.0.0.1
root@box:~#route add default gw 10.0.0.1
In Qemu2
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 30.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 30.0.0.1
root@box:~#route add default gw 30.0.0.1
Step 4:Frame Relay Switch Configuration
Command to enable Frame Relay in Cisco Router is
FRSW(config)#frame-relay switching
Now configure the interface serial1/0 and interface serial 1/1 with this command,
FRSW(config)#interface serial 1/0
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 102 interface serial 1/1 201
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
FRSW(config)#interface serial 1/1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 201 interface serial 1/0 102
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
Step 5:Configure the Router HO with static route for the network 30.0.0.0 and B0 for the network 10.0.0.0
In Head Office Router,
HO(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
In Branch Office Router,
BO(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
Step 6:Now go to the qemu host in 10.0.0.0 network and ping the host in 30.0.0.0 network
ping 30.0.0.10
Troubleshooting commands,
HO#show frame-relay pvc
PVC Statistics for interface Serial1/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0
input pkts 38 output pkts 50 in bytes 3610
out bytes 4746 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 1 out bcast bytes 34
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:20:39, last time pvc status changed 00:19:39
HO#show frame-relay map
Serial1/0 (up): ip 20.0.0.2 dlci 102(0x66,0x1860), dynamic,
broadcast,, status defined, active
HO#show frame-relay lmi
LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = CISCO
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 149 Num Status msgs Rcvd 133
Num Update Status Rcvd 0 Num Status Timeouts 16
To check packets belongs to frame relay
HO#debug frame-relay lmi
HO#debug frame-relay
HO#debug frame-relay packet
Post a Comment