In this post we are going to see how to configure Frame Relay Traffic Shaping point to point frame relay connection between Head Office Router and Branch Office Router.
Step 1:Create topology like this,
Step 2:Configure Head Office router and Branch Office router with ip address and make sure serial interface encapsulation that connected to FRSW is 'frame relay' on both Head office and Branch office router.
In Router HO Global Configuration mode,
HO(config)#interface fastethernet2/0
HO(config-if)#ip address 10.0.0.1 255.0.0.0
HO(config-if)#no shutdown
HO(config-if)#exit
HO(config)#interface serial 1/0
HO(config-if)#ip address 20.0.0.1 255.0.0.0
HO(config-if)#encapsulation frame-relay
HO(config-if)#no shutdown
HO(config-if)#exit
In Router BO Global Configuration mode,
BO(config)#interface fastethernet 2/0
BO(config-if)#ip address 30.0.0.1 255.0.0.0
BO(config-if)#no shutdown
BO(config-if)#exit
BO(config)#interface serial 1/0
BO(config-if)#ip address 20.0.0.2 255.0.0.0
BO(config-if)#encapsulation frame-relay
BO(config-if)#no shutdown
BO(config-if)#exit
Step 3:Configure the Qemu host with ip address and default gateway like i have given in a topology.I am using qemu host with microcore image, to configure this host follow this instructionRight click on Qemu host and start the host and wait for few minutes to boot, then configure ip address and default gateway with this command below.
In Qemu1,
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 10.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 10.0.0.1
root@box:~#route add default gw 10.0.0.1
In Qemu2
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 30.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 30.0.0.1
root@box:~#route add default gw 30.0.0.1
Step 4:Frame Relay Switch Configuration
Command to enable Frame Relay in Cisco Router is
In Global Config mode,
FRSW(config)#frame-relay switching
Now configure the interface serial1/0 and interface serial 1/1 with this command,
In Global Config mode,
FRSW(config)#interface serial 1/0
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 102 interface serial 1/1 201
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
FRSW(config)#interface serial 1/1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 201 interface serial 1/0 102
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
Step 5:Configure the Router HO with static route for the network 30.0.0.0 and B0 for the network 10.0.0.0
In Head Office Router,
HO(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
In Branch Office Router,
BO(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
Frame Relay Traffic Shapping configuration,
CIR-Committed Information Rate
Committed Information Rate is the maximum speed in bits gauranteed by the ISP for the virtual Circuits under normal condition.The traffic rate above CIR will be Discard Eligible(DE).
AR-Available Rate
This is the maximum traffic rate decided by the physical interface using clock rate command or by frame relay service provider.
Min CIR - Minimum Comitted Information Rate
This is the minimum traffic rate the router speed will drop down when congestion occurs on a frame relay network.Min CIR is half of the speed in a CIR.
DE -Discard Eligible
A bit that is set for traffic sent above the CIR will be Discard Eligible (DE).
BC-Commited Burst
The amount of bits sent during a specific interval,measured as Time committed(Tc).Time Committed is measured in milliseconds(default is 125ms 8 intervals per second).
CIR=Bc X 1000/Tc
BE-Excess Burst
Bits that exceeding the committed burst is Excess Burst(BC) and it is marked a Discard Eligible.
Interface with Default Band Width
HO#show interface serial1/0
Serial1/0 is up, line protocol is down
Hardware is M8T-X.21
Internet address is 20.0.0.1/8
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
Now, I am going to change the HO router serial interface bandwidth to 64000 bits/sec and BO router serial interface bandwidth to 128000 bits/sec.
Step 6:Cofigure HO Serial interface Bandwidth to 64000
HO(config)#interface serial1/0
HO(config-if)#bandwidth 64000
HO(config-if)#exit
HO#show interfac ser1/0
Serial1/0 is up, line protocol is up
Hardware is M8T-X.21
Internet address is 20.0.0.1/8
MTU 1500 bytes, BW 64000 Kbit, DLY 20000 usec,
Step 7:Cofigure BO Serial interface Bandwidth to 128000
BO(config)#interface serial1/0
BO(config-if)#bandwidth 128000
BO(config-if)#exit
BO#show interfac serial1/0
Serial1/0 is up, line protocol is up
Hardware is M8T-X.21
Internet address is 20.0.0.2/8
MTU 1500 bytes, BW 128000 Kbit, DLY 20000 usec,
Here,In above two routers BO have higher rate than HO router so we have configure frame relay traffic shaping in BO router.Otherwise it will over run HO router serial interface by sending higher traffic.
Step 8:Configure the frame relay traffic shaping in BO router,
In router BO,
BO(config)#map-class frame-relay BOCLASS
BO(config-map-class)#frame-relay cir 64000
BO(config-map-class)#frame-relay mincir 32000
BO(config-map-class)#frame-relay bc 4000
BO(config-map-class)#frame-relay be 4000
BO(config-map-class)#frame-relay adaptive-shaping becn
BO(config-map-class)#exit
BO(config)#interface ser1/0
BO(config-if)#frame-relay traffic-shaping
BO(config-if)#frame-relay class BOCLASS
BO(config-if)#exit
Target Rate = CIR = 64000 bits/s
Mincir = CIR/2 = 64000/2 = 32000 bits/s
Sustain = Bc = 4000 bits/int
Excess = Be = 4000 bits/int
Interval = Bc/CIR = 4000/64000 = 62 ms
Increment = Bc/8
Byte Limit = Increment + Be/8
BO#show traffic-shape
Interface Se1/0
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
201 64000 1000 4000 4000 62 496 BECN
Troubleshooting commands,
HO#show frame-relay pvc
HO#show frame-relay map
HO#show frame-relay lmi
HO#debug frame-relay lmi
HO#debug frame-relay
HO#debug frame-relay packet
HO#show traffic-shape statistics
HO#show traffic-shape
Step 1:Create topology like this,
Step 2:Configure Head Office router and Branch Office router with ip address and make sure serial interface encapsulation that connected to FRSW is 'frame relay' on both Head office and Branch office router.
In Router HO Global Configuration mode,
HO(config)#interface fastethernet2/0
HO(config-if)#ip address 10.0.0.1 255.0.0.0
HO(config-if)#no shutdown
HO(config-if)#exit
HO(config)#interface serial 1/0
HO(config-if)#ip address 20.0.0.1 255.0.0.0
HO(config-if)#encapsulation frame-relay
HO(config-if)#no shutdown
HO(config-if)#exit
In Router BO Global Configuration mode,
BO(config)#interface fastethernet 2/0
BO(config-if)#ip address 30.0.0.1 255.0.0.0
BO(config-if)#no shutdown
BO(config-if)#exit
BO(config)#interface serial 1/0
BO(config-if)#ip address 20.0.0.2 255.0.0.0
BO(config-if)#encapsulation frame-relay
BO(config-if)#no shutdown
BO(config-if)#exit
Step 3:Configure the Qemu host with ip address and default gateway like i have given in a topology.I am using qemu host with microcore image, to configure this host follow this instructionRight click on Qemu host and start the host and wait for few minutes to boot, then configure ip address and default gateway with this command below.
In Qemu1,
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 10.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 10.0.0.1
root@box:~#route add default gw 10.0.0.1
In Qemu2
tc@box:~$
tc@box:~$ sudo su
root@box:~#ifconfig eth0 30.0.0.10 netmask 255.0.0.0 up
root@box:~#route add ip default gw 30.0.0.1
root@box:~#route add default gw 30.0.0.1
Step 4:Frame Relay Switch Configuration
Command to enable Frame Relay in Cisco Router is
In Global Config mode,
FRSW(config)#frame-relay switching
Now configure the interface serial1/0 and interface serial 1/1 with this command,
In Global Config mode,
FRSW(config)#interface serial 1/0
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 102 interface serial 1/1 201
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
FRSW(config)#interface serial 1/1
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay route 201 interface serial 1/0 102
FRSW(config-if)#no shutdown
FRSW(config-if)#exit
Step 5:Configure the Router HO with static route for the network 30.0.0.0 and B0 for the network 10.0.0.0
In Head Office Router,
HO(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
In Branch Office Router,
BO(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
Frame Relay Traffic Shapping configuration,
CIR-Committed Information Rate
Committed Information Rate is the maximum speed in bits gauranteed by the ISP for the virtual Circuits under normal condition.The traffic rate above CIR will be Discard Eligible(DE).
AR-Available Rate
This is the maximum traffic rate decided by the physical interface using clock rate command or by frame relay service provider.
Min CIR - Minimum Comitted Information Rate
This is the minimum traffic rate the router speed will drop down when congestion occurs on a frame relay network.Min CIR is half of the speed in a CIR.
DE -Discard Eligible
A bit that is set for traffic sent above the CIR will be Discard Eligible (DE).
BC-Commited Burst
The amount of bits sent during a specific interval,measured as Time committed(Tc).Time Committed is measured in milliseconds(default is 125ms 8 intervals per second).
CIR=Bc X 1000/Tc
BE-Excess Burst
Bits that exceeding the committed burst is Excess Burst(BC) and it is marked a Discard Eligible.
Interface with Default Band Width
HO#show interface serial1/0
Serial1/0 is up, line protocol is down
Hardware is M8T-X.21
Internet address is 20.0.0.1/8
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
Now, I am going to change the HO router serial interface bandwidth to 64000 bits/sec and BO router serial interface bandwidth to 128000 bits/sec.
Step 6:Cofigure HO Serial interface Bandwidth to 64000
HO(config)#interface serial1/0
HO(config-if)#bandwidth 64000
HO(config-if)#exit
HO#show interfac ser1/0
Serial1/0 is up, line protocol is up
Hardware is M8T-X.21
Internet address is 20.0.0.1/8
MTU 1500 bytes, BW 64000 Kbit, DLY 20000 usec,
Step 7:Cofigure BO Serial interface Bandwidth to 128000
BO(config)#interface serial1/0
BO(config-if)#bandwidth 128000
BO(config-if)#exit
BO#show interfac serial1/0
Serial1/0 is up, line protocol is up
Hardware is M8T-X.21
Internet address is 20.0.0.2/8
MTU 1500 bytes, BW 128000 Kbit, DLY 20000 usec,
Here,In above two routers BO have higher rate than HO router so we have configure frame relay traffic shaping in BO router.Otherwise it will over run HO router serial interface by sending higher traffic.
Step 8:Configure the frame relay traffic shaping in BO router,
In router BO,
BO(config)#map-class frame-relay BOCLASS
BO(config-map-class)#frame-relay cir 64000
BO(config-map-class)#frame-relay mincir 32000
BO(config-map-class)#frame-relay bc 4000
BO(config-map-class)#frame-relay be 4000
BO(config-map-class)#frame-relay adaptive-shaping becn
BO(config-map-class)#exit
BO(config)#interface ser1/0
BO(config-if)#frame-relay traffic-shaping
BO(config-if)#frame-relay class BOCLASS
BO(config-if)#exit
Target Rate = CIR = 64000 bits/s
Mincir = CIR/2 = 64000/2 = 32000 bits/s
Sustain = Bc = 4000 bits/int
Excess = Be = 4000 bits/int
Interval = Bc/CIR = 4000/64000 = 62 ms
Increment = Bc/8
Byte Limit = Increment + Be/8
BO#show traffic-shape
Interface Se1/0
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
201 64000 1000 4000 4000 62 496 BECN
Troubleshooting commands,
HO#show frame-relay pvc
HO#show frame-relay map
HO#show frame-relay lmi
HO#debug frame-relay lmi
HO#debug frame-relay
HO#debug frame-relay packet
HO#show traffic-shape statistics
HO#show traffic-shape
Post a Comment